BuddyPress 2.8 requires PHP 5.3+
Starting with version 2.8, the minimum version of PHP required to run BuddyPress is 5.3.
PHP is the server-side programming language that powers WordPress and BuddyPress. Old versions of PHP are potentially unstable and insecure, and are missing some features that can be used to make BuddyPress faster and more powerful. The change is especially marked with the jump from PHP 5.2 to PHP 5.3, and the BuddyPress team has decided that now is the time to make the move.
Site administrators are strongly encouraged to run the latest stable version of all server software, including PHP.
See our PHP version compatibility guidelines for more details on how BP’s PHP version support is determined.
Starting with version 2.7, BuddyPress creates a notice in the Dashboard if it detects that your installation doesn’t meet the minimum requirements for version 2.8+. If you reached this page via this kind of notice, then your server needs to be upgraded.
You can also check your PHP version using your hosting tools. For example, here is a tutorial from InMotion Hosting on using cPanel to view your PHP version.
Most popular webhosts have an interface for changing PHP version. Check your host’s documentation or support for more details. A few examples:
When in doubt, contact your host’s support.
BuddyPress 2.8 and later are completely incompatible with PHP 5.2: activating the plugin on an unsupported version of PHP will result in fatal errors.
BuddyPress 2.7 includes PHP version detection. If BP 2.7 detects that you are running PHP 5.2, it attempts to prevent you from upgrading to BP 2.8+ via all the normal WordPress upgrade paths (like Dashboard > Plugins). In this situation, your site will run BP 2.7.x until PHP has been upgraded.