Skip to:
Content
Pages
Categories
Search
Top
Bottom

Theme Compatibility 1.7

The pages under this section provide an overview of the BuddyPress theme compatibility layer first introduced in version 1.7.

An overview of theme compatibility is provided as a primer followed by a detailed explanation of the template hierarchy provided and expanded on in BP 1.8 finally we provide a guide page for those of you wanting to upgrade your installs from the now redundant Template Pack Plugin approach to this far more flexible theme compatibility approach.

Theme Compatibility – an introduction.

Theme Compatibility – the template Hierarchy in detail.

Upgrading template packed themes to 1.7 theme compatibility.